View Posts
MatterHackers Forum
This forum has been set to read-only for archival purposes. Please visit our Community Forum to ask and participate in active discussions.
Remove Post
Can not get MatterControl 1.4.0 Mac to open in El Capitan 10.11.1
by Doug

The program installs fine, but when I try to launch it, it bounces for a second then closes. 10+ tries, and 3 reinstalls, to no avail. I've even updated my System Settings to allow apps downloaded from "Anywhere".

Any tips or tricks to get this program to launch on an up to date Mac?

Doug - November 10th, 2015 at 5:04p.m.

I have the same problem: impossible to open Matter control with theMacOS 10.11 El Capitan

phidab - November 11th, 2015 at 3:28a.m.

i have tried EVERYTHING with el cap and matter control.
I was having issues of MC not opening, operating erratically. El Cap gave me no USB connectivity to both my shapeoko and rostock. Plus my Griffin Firewave finally would not install.
Rolled back to Yosemite and everything is smoother. Perhaps it is because my mac is a 2008 with various video/hard drive hacks. End of the road for a tower that has served me well. Unfortunately no more OS X updates.
- James

jameskuehn - November 11th, 2015 at 7:54a.m.

Ooof. I sure hope that rolling my Mac backwards isn't the only choice. The good news is that I'm using MatterControl on the MatterControl Touch - and it works great with my Lulzbot Mini. I just want a way to transfer my files over to the Touch without cumbersome memory card swaps.

If anyone has had luck making a MatterControl install and launch on El Capitan, please sound off. (Or if there's a browser version that allows me to send files to my Touch that I haven't figured out, please let me know!)

Doug - November 11th, 2015 at 9:01a.m.

Hi everyone!

Thanks for your posts. As you can imagine, we've seen some mixed results with MatterControl and El Capitan. Some users report it works just fine; others are having the trouble you all seem to be experiencing.

Unfortunately we don't have any solutions to offer as of yet, and we're still collecting data in order to troubleshoot. If you're willing to help, the following instructions should give us a little more information about what's going on:

First, you'll need to launch MatterControl using a special file located in the application's package contents. Navigate to the Applications folder and right click on MatterControl. Choose 'Show Package Contents'. Navigate to Contents -> MacOS and double click the MatterControlMac file. This will open a terminal window that will return the raw output of the MatterControl application as it operates. This is what we need to see.

Assuming you're able to and the window doesn't close due to a crash, copy all output from the OS X Terminal window, paste it into a text file, and save it with the name OSX_terminal_output.txt. Attach the file in an email to and explain the circumstances that leads to the crash.

I realize this is a bit involved, but if we can get this information we'll be much better equipped to provide an answer and hopefully a solution. Thanks!

ryan.lutz - November 11th, 2015 at 2:17p.m.

Hey fellow Mac users, I just wanted to post one more comment here with the process I used to get MatterControl to install in my El Capitan OS.

First, install the program so it's in your Applications. It will fail to launch, but that's okay. Next, go to your Finder and from the top menu select Go > Go To Folder. This will bring up a text input window, and type in /Users/[YOUR USER NAME HERE]/.local/ If you put your user name in (without the brackets of course), you should see a window pop up with a single folder inside called "share". Click on that folder and select "Get Info". At the bottom of the pop up you'll see "Sharing and Permissions". Click the lock in the lower right corner, and input your password. And finally, change all privileges to "Read & Write" then click the lock to save your changes. When you launch MatterControl, you'll see a MatterControl folder pop up in the Share folder, and the program will finally open!

This worked for me, and hopefully it works for anyone else having issues launching the program in El Capitan!

InventiveHero - November 13th, 2015 at 6:30a.m.

Thanks for sharing!

I'll make a note for the development team about the permissions issue.

ryan.lutz - November 13th, 2015 at 10:28a.m.

Same here. A click, a few bounces then decides, "Nope. Not today sucker." I've sent in the 'terminal output' file to matterhackers. Hoping for a quick fix or update. Hoping not to have to learn/purchase other software. I was hopeful for InventiveHero's fix to work but did not for me. I'm currently in the process of trying to roll back to Yosemite in the mean time (and have since turned off automatic updates) so I can print some fidgets for my middle schoolers this weekend. If anyone else comes up with a work around, please share!

rockjock01 - December 5th, 2015 at 10:38a.m.

I tried the share and permissions method. It didn't work for me, either. Any news on this from the development team?

JR - December 15th, 2015 at 1:00p.m.

@JR They're working on it, and expect to have something ready for stable release in a few weeks.

There is a chance that we will have an alpha build available for testing this week or next. If so, I'll post a link here.

ryan.lutz - December 16th, 2015 at 10:28a.m.

I'm showing via terminal window an error message from MatterControl saying that it cannot load the default configuration file. To see if this is the same issue on your end, try this:

Ctrl-click on the MatterControl application icon, and choose the 'Show Package Contents' option

Click the arrow to the left of the Contents folder icon to show the subdirectories, and do the same for the MacOS directory that is shown

Double-click on the MatterControlMac icon

It will open a couple of terminal windows, and it took me multiple tries to see the stdout text, but it's definitely saying that it can't load the default config file.

Guest - December 16th, 2015 at 6:56p.m.

I was able to restore my app back to the version I was running before this update without issue via timemachine, which puts me at version 1.3.1. It seems to work fine.

k.meeks - December 17th, 2015 at 2:28p.m.